Sådan bruges den elektroniske DNI eller DNIe på en Mac

hvordan man bruger dnie på mac

Nu for tre år siden fornyede jeg mit identitetskort. Jeg havde den gamle version, som jeg tror jeg husker var et stort dokument med en blå baggrund, og at den mindste virkede noget "moderne" for mig, da jeg så chippen til det nye DNI tænkte jeg: «Og hvad er dette til ? ». Nå, det er chippen til DNIe, og som du alle ved, for eksempel ved "e" i "e-mail", betyder "e" normalt "elektronisk". Men hvad er det til? Hvordan bruger du DNIe på Mac?

DNIe er et dokument, der tjener til at udføre nogle Internetprocedurer, for eksempel. Det er ligesom at foretage banktransaktioner online, men logisk set med større sikkerhedsforanstaltninger. I en verden af ​​computere, hvor næsten alle bruger Windows, er det måske ikke så simpelt at få det til at arbejde på Mac, og det er derfor, vi besluttede at skrive denne lille guide. Dernæst fortæller vi dig alt, hvad du skal vide for at bruge DNIe på Mac og ikke prøve.

Før du begynder selvstudiet, skal du vide, at du har brug for en elektronisk ID-læser for at gennemføre hele processen. Hvis du stadig ikke har en, nedenfor har du et udvalg af de bedste kvalitetsprismodeller, så du kan bruge dit elektroniske id på din Mac. Hvis du allerede har en, starter vi processen trin for trin.

Hvor downloades certifikatet til DNIe

hvordan man bruger dnie på mac

Før du foretager nogen form for ny installation (uden opdatering, selvfølgelig), er det værd at sørge for, at vi ikke har nogen resten af ​​en mulig tidligere installation. Hvis vi er sikre på, at vi aldrig har brugt det, kan vi gå direkte til installationen af ​​de nye drivere. Hvis ikke, fjerner vi spor ved at gøre følgende:

  1. Vi åbner terminalen. Det er i mappen Applikationer / Hjælpeprogrammer, fra Launchpad i Dock eller søger efter det fra Spotlight.
  2. vi skriver dsenableroot for at aktivere superbruger.
  3. Det vil bede os om adgangskoden til vores bruger. Vi introducerer det.
  4. Det vil også bede os om rodadgangskoden. Vi introducerer den, vi ønsker, men det er det værd at være en, som vi kan huske, hvis vi nogensinde vil gøre ting som dette igen.
  5. Vi går til / Library og sletter Libpkcs11-dnie-mappen
  6. Vi åbner en terminal og indtaster følgende:
  7. sudo rm / var / db / kvitteringer / * dni *
  8. Nu deaktiverer vi rodkontoen med kommandoen dsenableroot –d
  9. Nu hvor vi har alt rent, er vi bare nødt til at gå til DENNE SIDE, download filerne og installer dem.

Sådan bruges det elektroniske DNI på Mac

Når filen allerede er installeret, en installation så simpelt som at dobbeltklikke på .pkg-filen og følge instruktionerne (herunder at sætte vores brugeradgangskode), fortsætter vi til konfigurere og bruge DNIe på Mac. Vi gør det ved at følge disse trin:

  1. Den første ting, vi skal gøre er, hvis vi ikke har det installeret, skal du gå til Mozilla-side, download og installer Firefox-webbrowseren. Historisk set har Safari ikke været sammen med mange websider, og det er noget, der også sker i denne type certifikater, det fungerer ikke med standardbrowseren i OS X. Under alle omstændigheder er det altid værd at have en anden webbrowser, for hvad der kan ske, og for mig er Firefox den næstbedste mulighed for mac.
  2. Det næste trin er at installere certifikatet i Firefox. For at gøre dette åbner vi Firefox, det gør vi Præferencer / Avanceret / Certifikater og klik på Sikkerhedsanordninger. hvordan man bruger dnie på mac
  3. Vi klikker på belastning.
  4. Vi giver modulet et navn (for eksempel DNIe PKCS 11-modul).
  5. Vi angiver manuelt stien til modulet, som vil være følgende: Bibliotek / Libpkcs11-dnie / lib / libpkcs11-dnie.so
  6. Vi klikker på accept.

hvordan man bruger dnie på mac

  1. For at installere rodcertifikatet skal vi Præferencer / Avanceret /Certifikater/ Se certifikater / autoriteter.
  2. Vi vælger Importer. hvordan man bruger dnie på mac
  1. Vi navigerer til stien til det certifikat, der vil være i / Bibliotek / Libpkcs11-dnie. I mit tilfælde var det direkte i den mappe. Hvis det ikke er der, ser vi efter det i mappen Share inden for den samme sti.
    hvordan man bruger dnie på mac
  2. Vi markerer de tre felter.
  3. Endelig klikker vi på OK.
    hvordan man bruger dnie på mac

Det er valgfrit, men anbefales, Genstart computeren for ikke at løbe ind i et uventet problem. Når det er genstartet, skal alt fungere uden problemer. Det ville også være interessant ikke at forbinde DNIe-læseren, før Mac'en er startet.

til kontrollere, om alt fungerer korrekt, kan du få adgang denne side leveret af det samme nationale politi . Hvis siden ikke indlæses, er noget, vi har gjort, eller noget galt galt. Det kan f.eks. Være, at der ikke er indsat et kort. Det bedste i disse tilfælde er at fjerne og sætte USB på den elektroniske DNI-læser, kontrollere at der er et kort og genstarte igen. Hvis vi ikke finder fejlen, kan det være en god ide at starte forfra fra starten, men denne gang er alle trin nødvendige, herunder fjernelse af de tidligere versioner af driverne og certifikatet.

Det skal huskes, at certifikatet er kun gyldigt i 30 dage. Efter denne tid vil det være nødvendigt at downloade og installere certifikatet igen.

Elektronisk DNI-læser til Mac

Alt forklaret ovenfor hjælper os ikke, hvis vi ikke har en elektronisk ID-læser. På samme måde som vi har brug for en ekstern læser for at kunne læse SD-kort i en iMac, skal vi også købe en elektronisk ID-læser.

Hvilken læser er det værd at købe? Nå, det er spørgsmålet om million dollar. Der er mange muligheder, og mange af dem vil tjene os perfekt, men vi kan også finde noget online, der ikke er det værd. Hvad jeg normalt gør, når jeg vil købe noget, er kig ind Amazon, som for mig er den bedste onlinebutik, der findes. Derudover, selvom det er rigtigt, at nogle kommentarer kan købes eller svigagtige, forsøger Amazon at forhindre, at disse kommentarer vises på sin hjemmeside, så de fleste af de anmeldelser, vi læser, vil være sande.

CoolBox-reader-dnie

En god mulighed, som faktisk er sælger nummer 1 af denne type læser på Amazon, er Woxter Electronic DNI , men wow! Det er til Windows og Linux. Det CoolBox CRCOOCRE065 Den har en endnu bedre vurdering, og den er tilgængelig til Mac. Men vær forsigtig, og sørg altid for, at den er tilgængelig til Mac.

Qué Ved du allerede, hvordan du bruger den elektroniske DNI på Mac?


Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort. Obligatoriske felter er markeret med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Miguel sagde han

    Mange tak for vejledningen, meget nyttig og nem at lave

  2.   Amstradbruger sagde han

    Meget godt klaret vejledningen. Men ... Bruger nogen det elektroniske DNI?, En anden fejl i administrationen.

    1.    aemedia sagde han

      Hvordan kan du fortælle, at du ikke bor i udlandet 😉

  3.   Angel sagde han

    Tak, jeg havde forsøgt at installere det i lang tid, og der var ingen måde. Jeg havde det altid i windows, og jeg savnede det. Selvfølgelig er det meget nyttigt, i det mindste for mig.

  4.   Sergio Martos Sanchez sagde han

    Hej, jeg har et problem med terminalen, da den ikke genkender min rodadgangskode, formoder jeg, at jeg skal have en allerede, og jeg kan ikke huske ... Er det muligt at vide det?
    Tak

    1.    Edu sagde han

      Test rod eller toor

  5.   Ricardo sagde han

    Hej til mig, installationsprogrammet fortæller mig, at der er opstået et problem, og at det ikke kun er blevet installeret

  6.   Ricardo sagde han

    Hej, jeg er i stand til at installere programmet, det giver mig en fejl, og installationen afsluttes ikke. Har du nogen idé?

  7.   Xavier sagde han

    Jeg har opgraderet til macOS Sierra og forsøger at installere .pkg-filen giver mig en fejl. Jeg antager, at vi bliver nødt til at vente på, at Sierra-pakken opdateres?

  8.   rfacal sagde han

    Det sker også for mig. Med Sierra er min DNIe stoppet med at arbejde

  9.   rfacal sagde han

    Brug af DNIe med en Mac er tortur. Takket være vejledningen offentliggjort i Soydemac Jeg havde opnået det: men min glæde i et hul med det nye Sierra OS. Det er vigtigt for mit arbejde at have en digital signatur, det være sig FNMT-certifikatet eller DNIe, og begge ting svigter mig. Jeg overvejer at købe en pc med Windows (og endda bruge Explorer, som tilsyneladende er det eneste, der genkender FNMT og DNIe godt). Efter 25 år kun at have brugt en Mac, virker det som en dårlig idé for mig, og jeg er sikker på, at det vil være mine andre fiskeelskeres joke. Kunne nogen med rimelighed forvente, at DNIe kan fungere på en opdateret Mac? (eller certifikatet: det er lige meget for mig: Jeg foretrækker det næsten. Da det virkede, var det hurtigere)

    1.    mag sagde han

      Og er det ikke nemmere og billigere at installere Windows på din Mac og bruge det via boot camp eller oprette en virtuel maskine ved hjælp af VMWare? Under alle omstændigheder er jeg enig med dig, at bruge DNIe på Mac er tortur, men fejlen ligger hos administrationens ubrugelige. Jeg havde opnået det for længe siden, men nu har jeg haft brug for at bruge det igen, og der er ingen måde. Jeg ved ikke, om det er fordi jeg bruger beta af macOS, gå til at vide. Det, jeg tidligere ikke havde problemer med, er med certifikatet, som du downloader fra FNMT og bruger det via Firefox, selvom de allerede tvinger dig til at bruge den browser i stedet for Safari, som er en anden.

  10.   javierfc sagde han

    Umuligt med Sierra

  11.   celiamoar sagde han

    Det lader mig ikke tilføje biblioteket / Libpkcs11-dnie / lib / libpkcs11-dnie.so-modulet

  12.   pedrazajaEngel sagde han

    Jeg kan ikke gøre det med Sierra, og jeg har brug for det. Har nogen været i stand til at installere det?

  13.   Estíbaliz Ivars Miralles sagde han

    du skal lave en master for at installere læseren, og der er ingen måde at få den på

  14.   Paco sagde han

    Umuligt med Sierra ... der er ingen måde

    1.    Xavier sagde han

      Løst! For at installere .pkj-pakken skal du have Firefox installeret på Mac'en, hvis den ikke er installeret, giver den en fejl, når du installerer .pkj. Når pakken er installeret, vil du se de trin, der skal følges for at konfigurere Firefox til at kunne bruge den med det elektroniske ID. Det ser ud til, at dette er den eneste browser, der fungerer med DNI på Mac, er Firefox

      1.    Susana sagde han

        Hej Javier:

        Kan du venligst angive, hvor de trin, der skal følges, vises, når du konfigurerer Firefox til at kunne bruge den med DNIe?

        Jeg har downloadet Firefox, og når jeg installerer pkg-filen, giver det mig en fejl.

        Mange tak!
        Susana

  15.   Ramon Martinez de Velasco sagde han

    Hej: Alt installeret og fungerer korrekt, men du siger: «Husk, at certifikatet kun er gyldigt i 30 dage. Efter denne tid vil det være nødvendigt at downloade og installere certifikatet igen. Hvor skal du downloade og geninstallere? Kan du give mig et link til siden, ikke et link til direkte download, tak? På forhånd mange tak. En hilsen.

  16.   Ramon Martinez de Velasco sagde han

    @Pablo Aparicio: Kan du svare på min kommentar, tak? På forhånd mange tak. Vær hilset.

    1.    yoshian sagde han

      Hej! Kan nogen hjælpe mig? Jeg har fulgt alle trin, men når jeg går ind på dit socialsikringswebsted, fortæller det mig, at der ikke er installeret nogen certifikater ...

  17.   Fabiola sagde han

    Jeg får en fejl, når jeg prøver at indlæse modulfilen?

    Mange tak for alt arbejdet

  18.   David sagde han

    God eftermiddag, lad os se om du kan hjælpe mig, når jeg installerer filen libpkcs11-dnie.so, fortæller det mig, at "Alert, modul kan ikke tilføjes." Ved du hvad du skal gøre?

    Mange tak.

  19.   Isabel sagde han

    Jeg har nøjagtigt det samme problem som David, samme fejlmeddelelse, når jeg prøver at indlæse modulet: "Alert, modulet kan ikke tilføjes"

  20.   Yesul sagde han

    Hej!! Jeg tror, ​​at den fejl, som PKG giver, er fordi Firefox ikke er installeret, det gav mig den samme fejl! Prøv det !!!

  21.   zurupeto sagde han

    Jeg downloader det forrige modul og lader mig skrue det op igen, jeg renser installationen og starter hele processen igen, men jeg er ikke i stand til at læse DNIe.

    MacBook Pro med Sierra OS

  22.   Yesul sagde han

    Jeg ved ikke, hvor mange gange jeg har installeret, slettet og geninstalleret det ved at følge alle trinene. I OSX HIGH SIERRA kender jeg det næsten udenad !!!!…. men når jeg prøver at få adgang til skattebureauet, giver det mig en fejl 403, det er desperat…. kan ikke få adgang til Dnie…. men for eksempel når firefox beder mig om at få adgang til certifikaterne, kommer det ind uden problemer…. Paul !!!! har du nogen idé om, hvad der kunne ske?

    nogen ved et eller andet sted, hvor de installerer det (selvfølgelig er jeg foran)

  23.   Jose sagde han

    Jeg har fulgt trinnene, og det virker ikke for mig, jeg gav en fejl, da modulet blev indlæst. Løsningen har været at LOGIN med den NYE PKCS # 11 MODUL. Skridt, der skal følges: åben mozilla> præferencer> privatliv og sikkerhed> sikkerhedsenheder> vælg NY PKCS @ 11 MODUL> klik på START SESSION> den beder om ID-kort> accepter. Derefter skal du lukke mozilla> kommando + Q helt og åbne mozilla igen. I det øjeblik genkender det allerede modulet og lader dig arbejde med DNIe.

    1.    Ramon sagde han

      Hej,

      Bare dette sker for mig: det fortæller mig, at det ikke kan indlæse DNIE-PKCS # 11-modulet, så downloader jeg det (jeg sletter det i Firefox-indstillinger) og genindlæser det, men START-knappen er inaktiv.

      Hvis jeg vælger læseren ("Generic Smart card ..." under DNIE-PKCS # 11-modulet) i specifikationerne står der "No present", så jeg sidder fast her.

      Min læser har en klassisk usb-forbindelse, men min MacBook Pro med OS Catalina har det mindste usb-stik (ovalt stik, som jeg ikke kan huske navnet), men det genkender læseren (Ewent 1052), fordi i «Om min Mac / USB »Det er der perfekt.

      En anden ting: certifikatet, der udløber om en måned, er det "ac_raiz_dnie.crt"? Downloades dette certifikat, når du installerer "libpkcs11-dnie-1.3.1_OSX-10.10_10.11.dmg"? Så hver gang du vil bruge DNI-E efter et stykke tid, bliver du nødt til at rense indstillingerne og geninstallere alt?

      Jeg vil sætte pris på hjælpen. Jeg ved ikke, om forummet stadig er i live. Jeg forlader min e-mail, hvis nogen går forbi og kan afklare min tvivl.

      Tak.

      Ramon T.
      ramontriba@gmail.com

  24.   Simon sagde han

    der er ingen måde at finde dette på:
    Vi navigerer til stien til certifikatet, der vil være i / Library / Libpkcs11-dnie. I mit tilfælde var det direkte i den mappe. Hvis det ikke er der, ser vi efter det i mappen Share inden for den samme sti.

  25.   Manuel Canteli Rodriguez sagde han

    det er en skam, men… .. man ender med at gå tilbage til Windows for noget så nødvendigt i vores dage som at bruge DNI-certifikatet. Ingen er klar over, at der er brugere, der ikke er programmører, og at vi er mere vant til et program, der beder os om at udfylde nogle felter, og at det ender med at installere det ønskede program? Det har UENDELIG været nemmere at installere hele Adobe-pakken end at forsøge at få det elektroniske ID til at fungere.
    Til sidst er alt, hvad jeg skal gøre, at bede min søn om at lade mig bruge sin pc.

  26.   Mari cruz sagde han

    Det samme sker for mig: Alert Det er ikke muligt at tilføje modulet. Brug af pengene i .Mac ser umuligt ud.

  27.   Aurelio sagde han

    Siden installation af Catalina…. Det er umuligt at bruge DNIe.

  28.   manual sagde han

    Jeg opgraderede til OS Catalina og måtte geninstallere alt.
    Tak for vejledningen

  29.   Jesus G. sagde han

    En masse opmærksomhed på dette: med hensyn til FIREFOX ser det ud til, at fra og med i dag (marts 2020) er kun FIREFOX 68-versionen gyldig.
    De senere er ikke gyldige, da de ikke indeholder en vigtig sikkerhedsmulighed for korrekt installation af certifikaterne.

    Dette er angivet på FNMT-siden i systemkravene til Mac.

  30.   natalia sagde han

    Jeg kan ikke installere det …….
    Jeg får to felter til at redigere tillid i stedet for tre….
    Der er ingen måde ...
    Hjælp

  31.   Mogli sagde han

    Tak, du reddede mig!

    1.    Oscar sagde han

      Hej, jeg lavede processen fra starten og slettede alle spor af mapper, som Pablo siger. Alt fungerer perfekt med Catalina og en bit4u DNIe-læser. Selvsignatur, ok. Signer PDF-filer digitalt med Adobe og DNIe, ok.
      Tak så meget !!

  32.   Churraco @ sagde han

    Mozilla Firefox-ruten er forældet både her og på siden for Spaniens misregering

  33.   anonym sagde han

    Det fungerer ikke på MacOS Big Sur.

  34.   Jose sagde han

    Godt.

    Jeg prøver at installere det på en Mac med Mojave (der er to versioner på politiets side 1.5.0 og 1.5.1, jeg prøver at installere 1.5.1). Det ser ud til at installere uden fejl. I slutningen af ​​installationen åbner den en Firefox-fane med instruktionerne angivet i "Sådan bruges det elektroniske DNI på Mac".

    Men når jeg indlæser modulet og går for at finde stien i biblioteket for at følge trinene, er der intet, der er ingen mappe "Libpkcs11-dnie". Så jeg kan ikke udføre de trin, Firefox fortæller mig.

    Er dette sket med en anden, hvordan kan det løses?

    Et andet spørgsmål, der måske lyder absurd, er det nødvendigt at have læseren tilsluttet USB under installationsprocessen og DNIe indsat i læseren? Dette kan have noget at gøre med ovenstående.

    Jeg er meget presserende med at rette op på dette for at fremlægge et dokument, og den tekniske support fra politiet hjælper mig ikke….

    Mange tak

  35.   Alejandra sagde han

    Hvis jeg har et FNMT-certifikat installeret, skal jeg da også slette det først? Eller er det ikke nødvendigt? Er det før jeg havde en NIE og havde FNMT-certifikatet til at udføre procedurer, men nu har jeg DNIe og ville installere dette ... det er klart, at teknologi ikke er min ting

  36.   Lorena sagde han

    HEJ. Jeg har købt den tillidslæser, som du anbefaler i artiklen, og jeg har en MAC HIGH SIERRA 10.13. tilsyneladende ikke understøttet. fordi når jeg har downloadet alt kortkortet, registrerer det ikke læseren for at starte sessionen.
    Hvilken læser anbefaler du til denne version af MAC? tak skal du have

  37.   Anna sagde han

    Det vil ikke lade mig downloade programmet, så jeg kan ikke gøre noget. Tolk, at det er en virus eller lignende. Jeg har prøvet det fra Safari og Chrome. Umulig.

  38.   Lola sagde han

    Jeg har formået at installere alt, jeg har bekræftet, at det virker efter politiets instruktioner, men når jeg vil bruge det på en anden side, giver det mig en fejl. Den beder mig altid om adgangskoden (indtast venligst adgangskoden til det elektroniske DNI-token PKCS#11.), som jeg forstår er det, jeg har sat på DNIe på politistationen, men det virker ikke. Er der nogen der ved hvad problemet er?

  39.   Xavier sagde han

    Mange tak. Du forklarer perfekt, hvordan man kommer ud af helvede: IT-forholdet til offentlige forvaltninger