How to install macOS Catalina on Macs that don't support it with DosDude

macos catalina

If you have a Mac where according to Apple you cannot install macOS Catalina, don't worry. There is a tool, DosDude, that will allow you to install the new macOS operating system on those computers. You already know that the compatible Macs are the MacBook Pro from 2015 onwards; MacBook Air, Mac Mini and Mac Pro since 2012; iMac Pro since 2017.

One of the sweet tooth options to be able to use our "old" Macs, is the Sidecar function that will allow you to use your iPad as a second screen for your Mac (this feature will not work in all because it is only compatible with specific Macs). But also the new security and privacy terms in which Apple. Let's see how we can bring that Mac back to life.

DosDude will make your older Mac work with macOS Catalina

Now, we have to add a small comment before we start to know how to install macOS Catalina on those Macs that are not supposed to be compatible. Computer performance can plummet, because this new operating system needs a lot of resources to function properly.

The only thing you have to do is download the necessary file from the official DosDude page. Before starting we must make a warning:

If you have a Mac that supports High Sierra natively, you have to be clear that you must have the most recent version of the system's BootROM installed. If you've never installed it, no problem, they also give you the opportunity to download it from the same page.

Another warning, which we always do when we are going to carry out any operation of this magnitude or similar. Make sure you have backups since when installing third-party applications and more specifically this operating system, contrary to what is advised by Apple, it can cause problems

The result that is obtained is that the list of computers that are compatible with macOS Catalina has grown exponentially:

  • Early 2008 or newer Mac Pro, iMac, or MacBook Pro:
    • MacPro 3,1; 4,1 and 5,1
    • iMac 8,1; 9,1; 10, x
    • iMac 11, x and 12, x
    • MacBookPro 4,1; 5, x; 6, x; 7, x and 8, x
  • MacBook MacBook Air late 2008 or newer:
    • MacBookAir 2,1; 3, x and 4, x
    • MacBook 5,1
  • MacBook early 2009 or newer:
    • Macmini 3,1; 4,1
    • Macmini 5, x (Systems with AMD Radeon HD 6xxx series GPUs will be nearly unusable when running Catalina.)
    • MacBook 5,2; 6,2 and 7,1
  • Xserve in early 2008 or later:
    • Xserve 2,1 and 3,1

The content of the article adheres to our principles of editorial ethics. To report an error click here!.

3 comments, leave yours

Leave a Comment

Your email address will not be published. Required fields are marked with *

*

*

  1. Responsible for the data: Miguel Ángel Gatón
  2. Purpose of the data: Control SPAM, comment management.
  3. Legitimation: Your consent
  4. Communication of the data: The data will not be communicated to third parties except by legal obligation.
  5. Data storage: Database hosted by Occentus Networks (EU)
  6. Rights: At any time you can limit, recover and delete your information.

  1.   cris said

    good to try

  2.   Christopher Orders said

    What happens if I install MacOs catalina on a 2011 computer but with intel i7 and 16gb in ram… Is it going to slow down? I tried a macbook air vs this team and the Air is much faster ...

  3.   Vanesa said

    Hello, I cannot download the system from the dosdude1 page, I get a security alert and there is no way. How can I get it? Thanks.