Macで電子DNIまたはDNIeを使用する方法

Macでdnieを使用する方法 XNUMX年前に身分証明書を更新しました。 私は古いバージョンを持っていましたが、それは青い背景の大きなドキュメントであり、最小のものは私にはやや「モダン」に見えたと思います。新しいDNIのチップを見たとき、私は次のように思いました。 ?»。 ええと、それはDNIeのチップであり、ご存知のように、たとえば、「電子メール」の「e」では、「e」は通常「電子」を意味します。 しかし、それは何のためですか? どのように使用しますか DNIe Mac?

DNIeは、いくつかの実行に役立つドキュメントです。 インターネット手続き、 例えば。 これは、オンラインで銀行取引を行うようなものですが、論理的には、より強力なセキュリティ対策が施されています。 ほとんどすべての人がWindowsを使用しているコンピューティングの世界では、WindowsをMacで動作させるのはそれほど簡単ではないかもしれません。そのため、この小さなガイドを作成することにしました。 次に、MacでDNIeを使用するために知っておく必要のあるすべてのことを説明します。

チュートリアルを開始する前に、プロセス全体を完了するには電子IDリーダーが必要であることを知っておく必要があります。 それでもお持ちでない場合は、Macで電子IDを使用できるように、以下に最高品質のモデルを選択します。すでにお持ちの場合は、プロセスを段階的に開始します。

DNIeの証明書をダウンロードする場所

Macでdnieを使用する方法

(もちろん、更新なしで)何らかの新規インストールを行う前に、インストールがないことを確認する価値があります。 可能な以前のインストールの残り。 使用したことがないと確信できる場合は、新しいドライバーのインストールに直接進むことができます。 そうでない場合は、次の手順でトレースを削除します。

  1. ターミナルを開きます。 それはフォルダにあります アプリケーション/ユーティリティ、DockのLaunchpadから、またはSpotlightから検索します。
  2. 私たちは、書き込み dsenableroot スーパーユーザーをアクティブ化します。
  3. ユーザーのパスワードの入力を求められます。 紹介します。
  4. また、rootパスワードの入力も求められます。 欲しいものを紹介しますが、このようなことをやり直したいときのために覚えておく価値があります。
  5. / Libraryに移動し、Libpkcs11-dnieフォルダーを削除します
  6. ターミナルを開き、次のように入力します。
  7. sudo rm / var / db /レシート/ * dni *
  8. ここで、コマンドdsenableroot –dを使用してrootアカウントを非アクティブ化します。
  9. すべてがきれいになったので、行かなければなりません このページ、ファイルをダウンロードしてインストールします。

Macで電子DNIを使用する方法

ファイルがすでにインストールされている状態で、.pkgファイルをダブルクリックし、指示(ユーザーパスワードの入力を含む)に従うだけの簡単なインストールに進みます。 MacでDNIeを構成して使用する。 次の手順に従って実行します。

  1. 最初に行う必要があるのは、インストールされていない場合は、 Mozillaページ、FirefoxWebブラウザをダウンロードしてインストールします。 歴史的に、Safariは多くのWebページとうまく調和しておらず、これはこのタイプの証明書でも発生し、OS Xのデフォルトのブラウザでは機能しません。いずれにせよ、XNUMX番目のWebブラウザを用意する価値は常にあります。何が起こるかについて、そして私にとってFirefoxはMacにとってXNUMX番目に良いオプションです。
  2. 次のステップは、Firefoxに証明書をインストールすることです。 これを行うには、Firefoxを開きます。 設定/詳細/証明書 クリックします 安全装置. Macでdnieを使用する方法
  3. クリックする ロード.
  4. モジュールに名前を付けます(たとえば、DNIe PKCS 11モジュール)。
  5. モジュールのパスを手動で指定すると、次のようになります。Library/ Libpkcs11-dnie / lib / libpkcs11-dnie.so
  6. [同意する]をクリックします。

Macでdnieを使用する方法

  1. ルート証明書をインストールするには、 設定/詳細/証明書/証明書を参照/当局.
  2. [インポート]を選択します。 Macでdnieを使用する方法
  1. にある証明書のパスに移動します /ライブラリ/ Libpkcs11-dnie。 私の場合、それはそのフォルダに直接ありました。 存在しない場合は、同じパス内の共有フォルダーで検索します。
    Macでdnieを使用する方法
  2. XNUMXつのボックスにマークを付けます。
  3. 最後に、[OK]をクリックします。
    Macでdnieを使用する方法

これはオプションですが、推奨されます。 コンピュータを再起動してください 予期しない問題が発生しないようにします。 再起動すると、すべてが問題なく動作するはずです。 Macが起動するまでDNIeリーダーを接続しないのも興味深いでしょう。

すべてが機能するかどうかを確認します 適切に、あなたはアクセスすることができます 国家警察が私たちに提供するこのページ 。 ページが読み込まれない場合は、何かを行ったか、問題が発生しています。 たとえば、カードが挿入されていない可能性があります。 このような場合の最良の方法は、電子DNIリーダーのUSBを取り外して入れ、カードがあることを確認して再起動することです。 障害が見つからない場合は、最初からやり直すことをお勧めしますが、今回は、以前のバージョンのドライバーと証明書の削除を含むすべての手順が必要になります。

覚えておいてください 証明書は30日間のみ有効です。 その後、証明書を再度ダウンロードしてインストールする必要があります。

Mac用の電子DNIリーダー

私たちが持っていない場合、上記で説明したすべては私たちを助けません 電子IDリーダー。 iMacでSDカードを読み取れるようにするために外部リーダーが必要になるのと同じように、電子IDリーダーも購入する必要があります。

どのリーダーを購入する価値がありますか? それは百万ドルの質問です。 多くのオプションがあり、それらの多くは私たちに完璧に役立ちますが、それだけの価値のないものをオンラインで見つけることもできます。 何かを買いたいときに普段やっていることは 覗く Amazon (アマゾン)、これは私にとって存在する最高のオンラインストアです。 さらに、一部のコメントが購入されたり詐欺されたりする可能性があることは事実ですが、AmazonはこれらのコメントがWebサイトに表示されないように努めているため、私たちが読んだレビューのほとんどは真実です。

CoolBox-reader-dnie

実際にAmazonでこのタイプのリーダーのナンバーワンの売り手である良いオプションは、 Woxter Electronic DNI 、でもすごい! WindowsとLinux用です。 ザ・ CoolBox CRCOOCRE065 それはさらに良い評価を持っており、Macで利用可能ですが、常にMacで利用可能であることを確認してください。

Macで電子DNIを使用する方法をすでに知っていますか?


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

46コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   ミゲル

    チュートリアルをありがとうございました、とても便利で簡単です

  2.   AmstradUser

    チュートリアルは非常によくできています。 しかし...誰かが電子DNIを使用していますか?、管理の別の失敗。

    1.    エメディア

      海外に住んでいないことをどうやって見分けることができますか😉

  3.   エンジェル

    おかげで、私は長い間それをインストールしようとしていました、そして方法がありませんでした。 私はいつもそれを窓に持っていて、私はそれを逃しました。 もちろん、少なくとも私にとっては非常に便利です。

  4.   セルジオマルトスサンチェス

    こんにちは、端末に問題があります。rootパスワードが認識されないため、すでに持っている必要があると思いますが、覚えていません…。 それを知ることは可能ですか?
    感謝

    1.    エドゥ

      ルートまたはtoorをテストします

  5.   リカルド

    こんにちは、インストーラーは問題が発生したことを教えてくれますが、インストールされたばかりではありません

  6.   リカルド

    こんにちは、プログラムをインストールできますが、エラーが発生し、インストールが完了しません。何かアイデアはありますか?

  7.   ザビエル

    macOS Sierraにアップグレードしましたが、.pkgファイルをインストールしようとするとエラーが発生します。 Sierraパッケージが更新されるのを待たなければならないと思いますか?

  8.   rfacal

    それは私にも起こります。 シエラで、私のDNIeは機能しなくなりました

  9.   rfacal

    MacでDNIeを使用するのは苦痛です。 Soydemacで公開されたチュートリアルのおかげで、私はそれを達成しました。しかし、新しいOSSierraでうまくいきました。 FNMT証明書であれDNIeであれ、私の仕事にはデジタル署名が不可欠であり、どちらも失敗します。 私はWindowsPCの購入を検討しています(そしてエクスプローラーを使用することさえ考えています。これは明らかにFNMTとDNIeがよく認識している唯一のものです)。 Macだけを使って25年経った今、それは悪い飲み物だと思います。それはきっと私の仲間の水槽の冗談でしょう。 DNIeがアップデートされたMacで動作することを合理的に期待できる人はいますか? (または証明書:それは同じです:私はほとんどそれを好みます。それがキャストされていたとき、それはより速かったです)

    1.    雑誌

      また、MacにWindowsをインストールしてブートキャンプ経由で使用したり、VMWareを使用して仮想マシンを作成したりする方が簡単で安価ではありませんか? とにかく、私はあなたに同意します、MacでDNIeを使うことは拷問です、しかし欠点は管理の役に立たないことにあります。 ずっと前に達成していましたが、今はまた使う必要があり、仕方がありません。 知っているmacOSのベータ版を使っているからなのかわかりません。 私が過去に問題を抱えていなかったのは、FNMTからダウンロードしてFirefoxを介して使用する証明書ですが、Safariの代わりにそのブラウザーを使用するように強制されています。

  10.   javierfc

    Sierraでは不可能

  11.   セリアモア

    Library / Libpkcs11-dnie / lib /libpkcs11-dnie.soモジュールを追加できません

  12.   ペドラサジャ天使

    私はシエラでそれをすることができません、そして私はそれを必要とします。 誰かがそれをインストールすることができましたか?

  13.   EstíbalizIvarsMiralles

    リーダーをインストールするにはマスターを実行する必要があり、それを取得する方法はありません

  14.   パコ

    Sierraでは不可能...方法はありません

    1.    ザビエル

      解決しました! .pkjパッケージをインストールするには、MacにFirefoxがインストールされている必要があります。インストールされていない場合は、.pkjのインストール時にエラーが発生します。 パッケージがインストールされると、電子IDで使用できるようにFirefoxを構成するための手順が表示されます。 MacのDNIで動作するブラウザはFirefoxだけのようです

      1.    スサーナ

        こんにちはハビエル:

        DNIeでFirefoxを使用できるように構成するときに、従う手順がどこに表示されるかを教えてください。

        Firefoxをダウンロードしましたが、pkgファイルをインストールするとエラーが発生します。

        どうもありがとう!
        スサーナ

  15.   ラモン・マルティネス・デ・ベラスコ

    こんにちは:すべてがインストールされ、正しく機能していますが、次のように述べています。«証明書は30日間のみ有効であることを忘れないでください。 その後、証明書を再度ダウンロードしてインストールする必要があります。 ダウンロードして再度インストールするものはどこにありますか? 直接ダウンロードリンクではなく、ページへのリンクを教えてください。 事前にどうもありがとうございました。 挨拶。

  16.   ラモン・マルティネス・デ・ベラスコ

    @Pablo Aparicio:私のコメントに答えていただけませんか。 事前にどうもありがとうございました。 ご挨拶。

    1.    よしあん

      こんにちは! 誰かが私を助けることができますか? すべての手順を実行しましたが、社会保障Webサイトにアクセスすると、証明書がインストールされていないと表示されます...

  17.   ファビオラ

    モジュールファイルを読み込もうとするとエラーが発生しますか?

    すべての作業をありがとうございました

  18.   デイビッド

    こんにちは、私を助けてくれるかどうか見てみましょう。libpkcs11-dnie.soファイルをインストールすると、「アラート、モジュールを追加できません」と表示されます。 何をすべきか知っていますか?

    どうもありがとうございます。

  19.   イザベル

    Davidとまったく同じ問題があり、モジュールを読み込もうとすると同じエラーメッセージが表示されます:「アラート、モジュールを追加できません」

  20.   シウル

    こんにちは!! PKGが出すエラーは、Firefoxがインストールされていないためだと思いますが、同じエラーが発生しました。 それを試してみてください !!!

  21.   ズルペト

    前のモジュールをダウンロードしてもう一度ねじ込み、インストールをクリーンアップしてプロセス全体を再開しましたが、DNIeを読み取ることができません。

    SierraOSを搭載したMacBookPro

  22.   シウル

    すべての手順を実行して、何回インストール、削除、再インストールしたかわかりません。OSXHIGHSIERRAでは、ほとんど心から知っています!!!!…。 しかし、税務署にアクセスしようとすると、エラー403が表示されます。必死です…。 Dnieにアクセスできません…。 しかし、例えば、Firefoxが私に証明書にアクセスするように頼んだとき、それは問題なく入ります…。 ポール!!!! あなたは何が起こり得るかについて何か考えがありますか?

    誰かがそれをどこにインストールするか知っています(明らかに私の前にいます)

  23.   ホセ

    手順を実行しましたが、機能しません。モジュールのロード時にエラーが発生しました。 解決策は、新しいPKCS#11モジュールでログインすることでした。 従う手順:mozillaを開く>設定>プライバシーとセキュリティ>セキュリティデバイス>新しいPKCS @ 11モジュールを選択>セッションの開始をクリック> IDカードを要求する>同意する。 次に、mozilla> command + Qを完全に閉じて、mozillaを再度開く必要があります。 その時点で、モジュールはすでに認識されており、DNIeを操作できます。

    1.    ラモン

      こんにちは、

      これは私に起こります:DNIE-PKCS#11モジュールをロードできないことを通知し、それをダウンロードして(Firefox設定内で削除します)、リロードしますが、[スタート]ボタンが非アクティブです。

      仕様でリーダー(DNIE-PKCS#11モジュールの下の「汎用スマートカード...」)を選択すると、「存在しません」と表示されるため、ここでスタックします。

      私のリーダーは古典的なUSB接続を持っていますが、OSCatalinaを搭載したMacBookProは最小のUSBソケット(名前を覚えていない楕円形のプラグ)を持っていますが、«私のMac / Usbについて»それは完全にあります。

      もう11つ、1.3.1か月で有効期限が切れる証明書は、「ac_raiz_dnie.crt」ですか? 「libpkcs10.10-dnie-10.11_OSX-XNUMX_XNUMX.dmg」をインストールすると、この証明書はダウンロードされますか? したがって、しばらくしてDNI-Eを使用するたびに、設定をクリーンアップしてすべてを再インストールする必要がありますか?

      私は助けに感謝します。 フォーラムがまだ生きているかどうかはわかりません。 誰かが通りかかった場合に備えてメールを残し、疑問を明確にすることができます。

      ありがとう。

      ラモンT。
      ramontriba@gmail.com

  24.   サイモン

    これを見つける方法はありません:
    / Library / Libpkcs11-dnieにある証明書のパスに移動します。 私の場合、それはそのフォルダに直接ありました。 存在しない場合は、同じパス内の共有フォルダーで検索します。

  25.   マヌエルカンテリロドリゲス

    残念ですが…..結局、DNI証明書を使用するなど、私たちの時代に必要な何かのためにWindowsに戻ることになります。 プログラマーではないユーザーがいて、いくつかのフィールドに入力するように求めるプログラムに慣れていて、最終的に目的のプログラムがインストールされることに誰も気づいていませんか? 電子IDを機能させるよりも、Adobeパッケージ全体をインストールする方がはるかに簡単です。
    結局、私がしなければならないのは息子に彼のPCを使わせてくれるように頼むことだけです。

  26.   マリクルス

    同じことが私にも起こります:アラートモジュールを追加できません。 .Macでお金を使うのは不可能に見えます。

  27.   アウレリオ

    Catalinaをインストールしてから…。 DNIeを使用することはできません。

  28.   マヌエル

    OS Catalinaにアップグレードし、すべてを再インストールする必要がありました。
    チュートリアルをありがとう

  29.   イエスG。

    これには多くの注意が払われています。FIREFOXに関しては、今日(2020年68月)現在、FIREFOXXNUMXバージョンのみが有効であるようです。
    後者は、証明書を正しくインストールするための基本的なセキュリティオプションが組み込まれていないため、無効です。

    これは、Macのシステム要件のFNMTページに示されています。

  30.   狭いです

    インストールできません……。
    信頼を編集するためのボックスがXNUMXつではなくXNUMXつあります…。
    道はない…。
    助けて

  31.   mogli

    ありがとう、あなたは私を救った!

    1.    オスカー

      こんにちは、私は最初からプロセスを実行し、Pabloが言うようにフォルダの痕跡をすべて消去しました。 Catalinaとbit4uDNIeリーダーですべてが完璧に機能します。 自己署名、わかりました。 AdobeとDNIeを使用してPDFにデジタル署名します。
      ありがとうございます!

  32.   チュラコ@

    Mozilla Firefoxルートは、こことスペインの誤政のページの両方で廃止されています

  33.   匿名の

    MacOS BigSurでは動作しません。

  34.   ホセ

    グッド。

    Mojaveを搭載したMacにインストールしようとしています(警察のページ1.5.0と1.5.1には1.5.1つのバージョンがあり、XNUMXをインストールしようとしています)。 エラーなしでインストールできるようです。 インストールが終了すると、「Macで電子DNIを使用する方法」に示されている手順でFirefoxタブが開きます。

    ただし、モジュールをロードしてライブラリ内のパスを見つけて手順を実行すると、何も表示されず、「Libpkcs11-dnie」フォルダもありません。 そのため、Firefoxから指示された手順を実行できません。

    これは他の誰かに起こったことがありますか、どうすれば修正できますか?

    ばかげているように聞こえるかもしれませんが、インストールプロセス中にリーダーをUSBに接続し、DNIeをリーダーに挿入する必要がありますか? これは上記と関係があるかもしれません。

    私はこれを修正して文書を提示することが非常に緊急であり、警察の技術サポートは私を助けません…。

    どうもありがとうございました

  35.   アレ

    FNMT証明書をインストールしている場合、最初にそれも削除する必要がありますか? それとも必要ありませんか? それは、NIEを取得し、手順を実行するためのFNMT証明書を取得する前でしたが、現在はDNIeを取得しており、これをインストールしたかったのです…。 明らかにテクノロジーは私のものではありません

  36.   ロリーナ

    こんにちは。 記事でお勧めのトラストリーダーを購入しました。MACHIGHSIERRA10.13を持っています。 どうやらサポートされていません。 すべてのマップカードをダウンロードしても、セッションを開始するリーダーが検出されないためです。
    このバージョンのMACにはどのリーダーをお勧めしますか? ありがとうございました

  37.   アンナ

    プログラムをダウンロードできないので、何もできません。 ウイルスなどと解釈してください。 SafariとChromeから試してみました。 不可能。

  38.   ローラ

    なんとかインストールできました。警察の指示に従って動作することを確認しましたが、他のページで使用したい場合はエラーになります。 常にパスワードを要求されます(PKCS#11電子DNIトークンのパスワードを入力してください)。これは私が警察署でDNIeに付けたものであると理解していますが、機能しません。 誰かが問題が何であるか知っていますか?

bool(true)