Hoe de elektronische DNI of DNIe op een Mac te gebruiken

hoe dnie te gebruiken op mac Nu drie jaar geleden heb ik mijn identiteitskaart vernieuwd. Ik had de oude versie, waarvan ik denk dat ik me herinner dat het een groot document was met een blauwe achtergrond en dat de kleinste mij enigszins 'modern' leek, toen ik de chip van de nieuwe DNI zag, dacht ik: 'En waar is dit voor ? ». Nou, het is de chip van de DNIe en, zoals jullie allemaal weten, bijvoorbeeld door de "e" in "e-mail", betekent de "e" meestal "elektronisch". Maar waar dient het voor? Hoe gebruik je de DNIe op Mac?

De DNIe is een document dat dient om enkele uit te voeren Internetprocedures, bijvoorbeeld. Het is zoiets als het online doen van banktransacties, maar logischerwijs met grotere beveiligingsmaatregelen. In een computerwereld waarin bijna iedereen Windows gebruikt, is het misschien niet zo eenvoudig om het op de Mac te laten werken, en daarom hebben we besloten deze kleine handleiding te schrijven. Vervolgens zullen we je alles vertellen wat je moet weten om de DNIe op Mac te gebruiken en niet te sterven terwijl je probeert.

Voordat u met de zelfstudie begint, moet u weten dat u een elektronische ID-lezer nodig heeft om het hele proces te voltooien. Als je er nog geen hebt, vind je hieronder een selectie van de modellen met de beste prijs-kwaliteitverhouding, zodat je je elektronische ID op je Mac kunt gebruiken.Als je er al een hebt, beginnen we stap voor stap met het proces.

Waar het certificaat voor DNIe downloaden

hoe dnie te gebruiken op mac

Voordat u een nieuwe installatie uitvoert (uiteraard zonder een update), is het de moeite waard om ervoor te zorgen dat we er geen hebben restant van een mogelijke eerdere installatie. Als we zeker weten dat we het nog nooit hebben gebruikt, kunnen we direct naar de installatie van de nieuwe stuurprogramma's gaan. Zo niet, dan verwijderen we eventuele sporen door het volgende te doen:

  1. We openen de terminal. Het staat in de map Toepassingen / hulpprogramma's, vanuit het Launchpad in het Dock of ernaar zoeken vanuit de Spotlight.
  2. we schrijven dsenableroot om superuser te activeren.
  3. Het zal ons om het wachtwoord van onze gebruiker vragen. We introduceren het.
  4. Het zal ons ook om het root-wachtwoord vragen. We introduceren degene die we willen, maar het is de moeite waard om er een te zijn die we kunnen onthouden voor het geval we dit soort dingen ooit nog een keer willen doen.
  5. We gaan naar / Library en verwijderen de map Libpkcs11-dnie
  6. We openen een terminal en voeren het volgende in:
  7. sudo rm / var / db / ontvangsten / * dni *
  8. Nu deactiveren we het root-account met het commando dsenableroot –d
  9. Nu we alles schoon hebben, moeten we gewoon naar toe DEZE PAGINA, download de bestanden en installeer ze.

Hoe de elektronische DNI op Mac te gebruiken

Met het bestand al geïnstalleerd, een installatie zo simpel als dubbelklikken op het .pkg-bestand en het volgen van de instructies (inclusief het invoeren van ons gebruikerswachtwoord), gaan we verder met configureer en gebruik DNIe op Mac. We zullen het doen door deze stappen te volgen:

  1. Het eerste dat we moeten doen, is, als we het niet hebben geïnstalleerd, naar het Mozilla-pagina, download en installeer de Firefox-webbrowser. Historisch gezien kon Safari niet goed overweg met veel webpagina's en dit is iets dat ook gebeurt in dit soort certificaten, het werkt niet met de standaardbrowser van OS X. Het is in ieder geval altijd de moeite waard om een ​​tweede webbrowser te hebben, voor wat er kan gebeuren, en voor mij is Firefox de op een na beste optie voor mac.
  2. De volgende stap is om het certificaat in Firefox te installeren. Om dit te doen, openen we Firefox, dat zullen we doen Voorkeuren / Geavanceerd / Certificaten en klik op Beveiligingen. hoe dnie te gebruiken op mac
  3. We klikken op Laden.
  4. We geven de module een naam (bijvoorbeeld DNIe PKCS 11 module).
  5. We geven handmatig het pad van de module aan, wat het volgende zal zijn: Bibliotheek / Libpkcs11-dnie / lib / libpkcs11-dnie.so
  6. We klikken op accepteren.

hoe dnie te gebruiken op mac

  1. Om het rootcertificaat te installeren, gaan we Voorkeuren / Geavanceerd /Certificaten/ Zie certificaten / autoriteiten.
  2. We selecteren Import. hoe dnie te gebruiken op mac
  1. We navigeren naar het pad van het certificaat dat binnenkomt / Bibliotheek / Libpkcs11-dnie. In mijn geval stond het rechtstreeks in die map. Als het er niet is, zoeken we het in de Share-map binnen hetzelfde pad.
    hoe dnie te gebruiken op mac
  2. We markeren de drie vakjes.
  3. Ten slotte klikken we op OK.
    hoe dnie te gebruiken op mac

Het is optioneel, maar aanbevolen, Start je computer opnieuw op om geen onverwachte problemen tegen te komen. Eenmaal opnieuw opgestart, zou alles zonder problemen moeten werken. Het zou ook interessant zijn om de DNIe-lezer niet aan te sluiten voordat de Mac is opgestart.

naar controleer of alles werkt correct, hebt u toegang tot deze pagina die de Nationale Politie ons ter beschikking stelt . Als de pagina niet laadt, hebben we iets gedaan of is er iets misgegaan. Het kan zijn dat er bijvoorbeeld geen kaart is geplaatst. In deze gevallen kunt u het beste de USB van de elektronische DNI-lezer verwijderen en weer terugplaatsen, controleren of er een kaart aanwezig is en opnieuw opstarten. Als we de fout niet vinden, kan het een goed idee zijn om vanaf het begin opnieuw te beginnen, maar deze keer zijn alle stappen nodig, inclusief het verwijderen van de vorige versies van de stuurprogramma's en het certificaat.

Er moet aan worden herinnerd dat de certificaat is slechts 30 dagen geldig. Na die tijd moet u het certificaat opnieuw downloaden en installeren.

Elektronische DNI-lezer voor Mac

Alles wat hierboven is uitgelegd, zal ons niet helpen als we geen elektronische ID-lezer. Op dezelfde manier dat we een externe lezer nodig hebben om SD-kaarten in een iMac te kunnen lezen, zullen we ook een elektronische ID-lezer moeten kopen.

Welke lezer is het waard om te kopen? Dat is de vraag van een miljoen dollar. Er zijn veel opties en veel daarvan zullen ons perfect van dienst zijn, maar we kunnen ook online iets vinden dat het niet waard is. Wat ik meestal doe als ik iets wil kopen, is kijk in Amazone, wat voor mij de beste online winkel is die er bestaat. Hoewel het waar is dat sommige opmerkingen kunnen worden gekocht of frauduleus zijn, probeert Amazon bovendien te voorkomen dat deze opmerkingen op zijn website verschijnen, dus de meeste beoordelingen die we lezen, zullen waar zijn.

CoolBox-lezer-dnie

Een goede optie, die in feite de nummer 1 verkoper is van dit type reader op Amazon, is de Woxter Electronic DNI , maar wauw! Het is voor Windows en Linux. De CoolBox CRCOOCRE065 Het heeft een nog betere beoordeling en is beschikbaar voor Mac. Maar wees voorzichtig, zorg er altijd voor dat het beschikbaar is voor Mac.

Qué Weet u al hoe u de elektronische DNI op Mac moet gebruiken?


De inhoud van het artikel voldoet aan onze principes van redactionele ethiek. Klik op om een ​​fout te melden hier.

46 reacties, laat de jouwe achter

Laat je reactie achter

Uw e-mailadres wordt niet gepubliceerd.

*

*

  1. Verantwoordelijk voor de gegevens: Miguel Ángel Gatón
  2. Doel van de gegevens: Controle SPAM, commentaarbeheer.
  3. Legitimatie: uw toestemming
  4. Mededeling van de gegevens: De gegevens worden niet aan derden meegedeeld, behalve op grond van wettelijke verplichting.
  5. Gegevensopslag: database gehost door Occentus Networks (EU)
  6. Rechten: u kunt uw gegevens op elk moment beperken, herstellen en verwijderen.

  1.   Miguel zei

    Heel erg bedankt voor de tutorial, erg handig en gemakkelijk te doen

  2.   Amstrad-gebruiker zei

    Heel goed gedaan de tutorial. Maar ... Gebruikt iemand de elektronische DNI? Nog een mislukking van de administratie.

    1.    aemedia zei

      Hoe weet je dat je niet in het buitenland woont 😉

  3.   Engel zei

    Bedankt, ik probeerde het al heel lang te installeren en dat lukte niet. Ik had het altijd in de ramen en ik miste het. Het is natuurlijk erg handig, althans voor mij.

  4.   Sergio Martos Sanchez zei

    Hallo, ik heb een probleem met de terminal, aangezien het mijn root-wachtwoord niet herkent, veronderstel ik dat ik er al een moet hebben en ik weet het niet meer…. Is het mogelijk om het te weten?
    bedankt

    1.    Edu zei

      Test root of toor

  5.   Ricardo zei

    Hallo, het installatieprogramma vertelt me ​​dat er een probleem is opgetreden en dat het niet zomaar is geïnstalleerd

  6.   Ricardo zei

    Hallo, ik kan het programma installeren, ik krijg een foutmelding en de installatie wordt niet voltooid. Enig idee?

  7.   Xavier zei

    Ik heb een upgrade naar macOS Sierra uitgevoerd en als ik probeer het .pkg-bestand te installeren, krijg ik een foutmelding. Ik denk dat we moeten wachten tot het Sierra-pakket is bijgewerkt?

  8.   rfacal zei

    Dat overkomt mij ook. Met Sierra werkt mijn DNIe niet meer

  9.   rfacal zei

    Het gebruik van de DNIe met Mac is een marteling. Dankzij de tutorial gepubliceerd in Soydemac had ik het bereikt: maar mijn plezier in een put met het nieuwe OS Sierra. Het is essentieel voor mijn werk om de digitale handtekening te hebben, of het nu het FNMT-certificaat of de DNIe is, en beide dingen schieten mij tekort. Ik overweeg om een ​​Windows-pc te kopen (en zelfs Explorer te gebruiken, wat het enige lijkt te zijn dat de FNMT en DNIe goed herkennen). Na 25 jaar alleen Mac te hebben gebruikt, vind ik het een slechte drank, en het zal zeker de grap zijn van mijn mede-aquariums. Kan iemand redelijke verwachtingen hebben dat de DNIe kan werken op een bijgewerkte Mac? (of het certificaat: het is hetzelfde: ik geef er bijna de voorkeur aan. Toen het aan het casten was, ging het sneller)

    1.    magazijn zei

      En is het niet eenvoudiger en goedkoper om Windows op je Mac te installeren en te gebruiken via bootcamp of om een ​​virtuele machine te maken met VMWare? Hoe dan ook, ik ben het met je eens, het gebruik van de DNIe op Mac is marteling, maar de fout ligt bij het nutteloze van de administratie. Ik had het lang geleden bereikt, maar nu moet ik het opnieuw gebruiken en er is geen manier. Ik weet niet of het komt omdat ik de bèta van macOS gebruik, wie weet. Waar ik in het verleden geen problemen mee had, is met het certificaat dat je downloadt van de FNMT en het gebruikt via Firefox, hoewel ze je al dwingen om die browser te gebruiken in plaats van Safari, wat een andere is.

  10.   javierfc zei

    Onmogelijk met Sierra

  11.   celiamoar zei

    Ik kan de module Library / Libpkcs11-dnie / lib / libpkcs11-dnie.so niet toevoegen

  12.   pedrazaja engel zei

    Ik kan het niet met Sierra en ik heb het nodig. Heeft iemand het kunnen installeren?

  13.   Estíbaliz Ivars Miralles zei

    je moet een master doen om de reader te installeren, en er is geen manier om het te krijgen

  14.   Paco zei

    Onmogelijk met Sierra ... er is geen manier

    1.    Xavier zei

      Opgelost! Om het .pkj-pakket te installeren, moet Firefox op de Mac zijn geïnstalleerd, als het niet is geïnstalleerd, geeft het een foutmelding bij het installeren van het .pkj. Nadat het pakket is geïnstalleerd, ziet u de stappen die u moet volgen om Firefox te configureren zodat u het met de elektronische ID kunt gebruiken. Het lijkt erop dat dit de enige browser is die werkt met de DNI op de Mac, Firefox

      1.    Susana zei

        Hallo Javier:

        Kunt u aangeven waar de te volgen stappen verschijnen bij het configureren van Firefox om het met de DNIe te kunnen gebruiken?

        Ik heb Firefox gedownload en bij het installeren van het pkg-bestand krijg ik een foutmelding.

        Thank you very much !!!
        Susana

  15.   Ramón Martínez de Velasco zei

    Hallo: Alles is geïnstalleerd en werkt correct, maar u zegt: «Onthoud dat het certificaat slechts 30 dagen geldig is. Na die tijd moet u het certificaat opnieuw downloaden en installeren. Waar is het ding om te downloaden en opnieuw te installeren? Kunt u mij een link naar de pagina geven, geen directe downloadlink? Alvast heel erg bedankt. Een begroeting.

  16.   Ramón Martínez de Velasco zei

    @Pablo Aparicio: Kunt u mijn opmerking beantwoorden, alstublieft? Alvast heel erg bedankt. Groeten.

    1.    Yoshian zei

      Hallo! Kan iemand mij helpen? Ik heb alle stappen gevolgd, maar wanneer ik uw socialezekerheidswebsite binnenkom, vertelt het me dat er geen certificaten zijn geïnstalleerd ...

  17.   Fabiola zei

    Ik krijg een foutmelding wanneer ik probeer het modulebestand te laden?

    Heel erg bedankt voor al het werk

  18.   David zei

    Goedemiddag, kijk of je me kunt helpen, wanneer ik het bestand libpkcs11-dnie.so installeer, wordt me verteld dat "Alert, module kan niet worden toegevoegd". Weet je wat ik moet doen?

    Heel hartelijk bedankt.

  19.   Isabel zei

    Ik heb exact hetzelfde probleem als David, dezelfde foutmelding bij het laden van de module: "Alert, de module kan niet worden toegevoegd"

  20.   Yesul zei

    Hallo daar!! Ik denk dat de fout die de PKG geeft is dat Firefox niet is geïnstalleerd, het gaf me dezelfde fout! probeer het !!!

  21.   Zurupeto zei

    Ik download de vorige module en laat me het weer verknoeien, ik maak de installatie schoon en start het hele proces opnieuw, maar ik kan de DNIe niet lezen.

    MacBook Pro met Sierra OS

  22.   Yesul zei

    Ik weet niet hoe vaak ik het heb geïnstalleerd, verwijderd en opnieuw geïnstalleerd, volgens alle stappen. In OSX HIGH SIERRA ken ik het bijna uit mijn hoofd !!!!…. maar als ik toegang probeer te krijgen tot de belastingdienst, krijg ik fout 403, het is wanhopig ... geen toegang tot de Dnie…. maar als firefox mij bijvoorbeeld vraagt ​​om toegang te krijgen tot de certificaten, komt het probleemloos binnen…. Paul !!!! heb je enig idee wat er kan gebeuren?

    iemand weet ergens waar ze het installeren (blijkbaar ben ik vooraan)

  23.   Jose zei

    Ik heb de stappen gevolgd en het werkt niet voor mij, ik heb een foutmelding gegeven bij het laden van de module. De oplossing was om in te loggen met de NIEUWE PKCS # 11-MODULE. Te volgen stappen: open mozilla> voorkeuren> privacy en beveiliging> beveiligingsapparaten> selecteer NIEUWE PKCS @ 11-MODULE> klik op SESSIE STARTEN> het zal om de ID-kaart vragen> accepteren. Dan moet je de mozilla> command + Q volledig sluiten en mozilla opnieuw openen. Op dat moment herkent het de module al en kun je met de DNIe werken.

    1.    Ramon zei

      Hallo,

      Dit gebeurt gewoon met mij: het vertelt me ​​dat het de DNIE-PKCS # 11-module niet kan laden, dan download ik het (ik verwijder het in Firefox-voorkeuren) en laad het opnieuw, maar de START-knop is inactief.

      Als ik de lezer selecteer ("Generic Smart card ..." onder de DNIE-PKCS # 11 module) in de specificaties staat er "No present", dus ik loop hier vast.

      Mijn reader heeft een klassieke usb-aansluiting maar mijn MacBook Pro met OS Catalina heeft de kleinste usb-aansluiting (ovale stekker waarvan ik de naam niet meer weet) maar hij herkent wel de reader (Ewent 1052), want in «Over mijn Mac / Usb »Het is er perfect.

      Nog iets: het certificaat dat binnen een maand verloopt, is het "ac_raiz_dnie.crt"? Wordt dit certificaat gedownload wanneer u "libpkcs11-dnie-1.3.1_OSX-10.10_10.11.dmg" installeert? Dus elke keer dat u de DNI-E na een tijdje wilt gebruiken, moet u de voorkeuren opschonen en alles opnieuw installeren?

      Ik zal de hulp waarderen. Ik weet niet of het forum nog leeft. Ik laat mijn e-mail achter voor het geval er iemand langskomt en kan mijn twijfels wegnemen.

      Dank u.

      Tegen Ramon T.
      ramontriba@gmail.com

  24.   Simon zei

    er is geen manier om dit te vinden:
    We navigeren naar het pad van het certificaat in / Library / Libpkcs11-dnie. In mijn geval stond het rechtstreeks in die map. Als het er niet is, zoeken we het in de Share-map binnen hetzelfde pad.

  25.   Manuel Canteli Rodriguez zei

    Het is jammer, maar ... je gaat terug naar Windows voor iets dat tegenwoordig zo noodzakelijk is, zoals het gebruik van het DNI-certificaat. Niemand realiseert zich dat er gebruikers zijn die geen programmeurs zijn en dat we meer gewend zijn aan een programma dat ons vraagt ​​om enkele velden in te vullen en dat het uiteindelijk het gewenste programma installeert? Het was ONEINDIG gemakkelijker om het volledige Adobe-pakket te installeren dan om te proberen de elektronische ID te laten werken.
    Uiteindelijk hoef ik mijn zoon alleen maar te vragen of ik zijn pc mag gebruiken.

  26.   Maria Cruz zei

    Hetzelfde gebeurt met mij: Alert De module kan niet worden toegevoegd. Het lijkt me onmogelijk om het geld in .Mac te gebruiken.

  27.   Aurelio zei

    Sinds het installeren van Catalina…. Het is onmogelijk om de DNIe te gebruiken.

  28.   Handboek zei

    Ik heb een upgrade naar OS Catalina uitgevoerd en alles opnieuw moeten installeren.
    Bedankt voor de tutorial

  29.   Jezus G. zei

    Veel aandacht hiervoor: met betrekking tot FIREFOX lijkt het erop dat vanaf vandaag (maart 2020) alleen de FIREFOX 68-versie geldig is.
    De latere zijn niet geldig, aangezien ze geen essentiële beveiligingsoptie bevatten om de certificaten correct te installeren.

    Dit wordt aangegeven op de FNMT-pagina, in de systeemvereisten voor Mac.

  30.   smal zei

    Ik kan het niet installeren …….
    Ik krijg twee vakken om vertrouwen te bewerken in plaats van drie….
    Er is geen manier….
    Helpen

  31.   vrouwen zei

    Bedankt, je hebt me gered!

    1.    Oscar zei

      Hallo, ik heb het proces vanaf het begin gedaan en alle sporen van mappen gewist, zoals Pablo zegt. Alles werkt perfect met Catalina en een bit4u DNIe-lezer. Zelf-handtekening, oké. Onderteken PDF's digitaal met Adobe en de DNIe, oké.
      Dank u !!

  32.   Churraco @ zei

    De Mozilla Firefox-route is zowel hier als op de Spaanse misbestuurpagina achterhaald

  33.   anoniem zei

    Het werkt niet op MacOS Big Sur.

  34.   Jose zei

    Goed.

    Ik probeer het te installeren op een Mac met Mojave (er zijn twee versies op de politiepagina 1.5.0 en 1.5.1, ik probeer 1.5.1 te installeren). Het lijkt te installeren zonder fouten. Aan het einde van de installatie wordt een Firefox-tabblad geopend met de instructies die worden aangegeven in "Hoe de elektronische ID op Mac te gebruiken".

    Wanneer ik de module echter laad en het pad in de bibliotheek ga zoeken om de stappen te volgen, is er niets, er is geen map "Libpkcs11-dnie". Dus ik kan de stappen die Firefox mij vertelt niet doen.

    Is dit iemand anders overkomen, hoe kan dit worden verholpen?

    Een andere vraag die misschien absurd klinkt, is het nodig om de lezer tijdens het installatieproces op de usb te hebben aangesloten en de DNIe in de lezer te plaatsen? Dit kan met het bovenstaande te maken hebben.

    Ik ben vrij dringend om dit op te lossen om een ​​document te overleggen en de technische ondersteuning van de politie helpt me niet….

    heel hartelijk bedankt

  35.   Alejandra zei

    Als ik een FNMT-certificaat heb geïnstalleerd, moet ik dit dan ook eerst verwijderen? Of is het niet nodig? Is dat voordat ik een NIE had en ik had het FNMT-certificaat om procedures te doen, maar nu heb ik de DNIe en wilde ik dit installeren…. het is duidelijk dat technologie niet mijn ding is

  36.   Lorena zei

    HALLO. Ik heb de trust reader gekocht die u in het artikel aanbeveelt en ik heb een MAC HIGH SIERRA 10.13. blijkbaar niet ondersteund. want wanneer ik alle kaartkaarten heb gedownload, wordt de lezer niet gedetecteerd om de sessie te starten.
    Welke lezer raadt u aan voor deze versie van MAC? Bedankt

  37.   Anna zei

    Ik kan het programma niet downloaden, dus ik kan niets doen. Interpreteer dat het een virus of iets dergelijks is. Ik heb het geprobeerd vanuit Safari en vanuit Chrome. Onmogelijk.

  38.   Lola zei

    Ik heb alles kunnen installeren, ik heb geverifieerd dat het werkt volgens de instructies van de politie, maar als ik het op een andere pagina wil gebruiken, krijg ik een foutmelding. Het vraagt ​​me altijd om het wachtwoord (Voer het wachtwoord voor de PKCS#11 elektronische DNI-token in.) waarvan ik begrijp dat het het wachtwoord is dat ik op de DNIe op het politiebureau heb gezet, maar het werkt niet. Weet iemand wat het probleem is?

bool (waar)