Apple förnyar säkerhetscertifikatet för både OS X-applikationer, push-meddelanden och Safari-tillägg samt för kort i Wallet

Säkerhetscertifikat-Safari-plånbok-0

För att skydda datans riktighet, företag utfärda säkerhetscertifikat som indikerar att utbytet av information eller data som utförs via en applikation, webbsida eller någon annan typ av plattform är legitimt och inte är en bluff som imiterar originalet som sker i olika fall av nätfiske.

Av denna anledning utfärdade Apple ett certifikat till utvecklare för länge sedan som certifierar användningen av både Apple Wallet-applikationen, som för meddelanden och tillägg i Safari och alla de tredjepartsapplikationer som används i OS X. Detta certifikat upphör dock att gälla i februari 2016 och det är därför de just har utfärdat ett nytt som kommer att gälla till 7 februari 2023.

Säkerhetscertifikat-Safari-plånbok-1

För att skydda kunder och utvecklare kräver vi att alla tredjepartsappar, kort i Apple Wallet, Safari-push-meddelanden och tillägg och App Store-inköpskvitton undertecknas av en betrodd certifikatutfärdare. Apple Worldwide Developer Relations Certification Intermediate Certificate utfärdar certifikaten som används för att signera din programvara på Apple-enheter, vilket i sin tur gör det möjligt för våra system att bekräfta att din programvara levereras till användarna som avsett och inte har ändrats.

Certifikatet utfärdades med en tidsfrist den 14 februari 2016 och en förnyad har just utfärdats som måste ingå i alla applikationer som skapats av utvecklare som integrerar paket som använder både Safari push-meddelanden och tillägg, Mac-applikationer och Apple Wallet. Dessutom, tillsammans med push-aviseringar, måste de också innehålla certifikatet på servern till validera kommunikationen och få den att fungera på klientdatorn.

Apple har också skapat en supportsida som beskriver hur utvecklare kan införliva och testa det nya certifikatet, där det också nämns att utvecklare inte behöver kompilera om eller skicka in ansökningar för granskning, även om de gör det. Som skickas in efter 14 februari 2016 och måste innehålla detta certifikat. Den kommande ändringen kommer inte att påverka iOS-användare, men OS X El Capitan-användare måste uppdatera till version 10.11.2. För sin del kommer Snow Leopard-användare att få en uppdatering i januari som gör det möjligt för dem att fortsätta köpa innehåll via Mac App Store.

 


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

Bli först att kommentera

Lämna din kommentar

Din e-postadress kommer inte att publiceras. Obligatoriska fält är markerade med *

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.